Faulty Fuel Injector - B3 2023

Faults and Technical chat for the Volvo XC40
Post Reply
Volvobadger
Posts: 55
Joined: Mon Oct 24, 2022 10:57 pm

Post by Volvobadger »

That's exactly what happened to mine pulled out of a side road into 60mph traffic with plenty of space, accelerated up to 60 - the tortoise flashed up when I got to about 40mph and the engine started juddering and slowing down.
Got to the traffic lights at the end of that road and it just stopped doing it and went back to normal.

Tom33
Posts: 8
Joined: Thu Jan 04, 2024 9:25 pm

Post by Tom33 »

As per Volvo dealer senior technician it is a common problem with new B3 and B4 engines. Apparently no solution from Volvo Sweden today. The car was twice for investigation in total for 4 working days. For me it happens early in the morning when engine is cold the effect like limp mode.
Deleted User 4737

Post by Deleted User 4737 »

It used to be known that bad plugs were worse when cold? It could be anything, but would suspect spark failure first?
ChrisLF
Posts: 1566
Joined: Wed Apr 24, 2019 8:21 am
Location: Heart of England

Post by ChrisLF »

From Tom33's post it doesn't sound like spark plugs!

Not good as far as safety is involved.
2023 B4 Plus Dark FWD in Silver Dawn. Tinted Rear Windows. Spare Wheel & Tow Bar dealer fitted.

Gone - 2019 T4 R-Design FWD in Bursting Blue. Winter & Convenience Packs, Power Seat, Front Park Assist, Rear Camera, Spare Wheel & Tow Bar.
Deleted User 4737

Post by Deleted User 4737 »

Can't rule out plugs - fuel-spark-bang. When an engine is juddering (miss-firing), the bang is missing. Suspect missing spark first, then fuel and so on - old school yes, but the fundamentals of the ICE have not changed in a 100+ years.
Deleted User 4868

Post by Deleted User 4868 »

This has happened to me once - the tortoise symbol coming up but with no reduction in performance. I was driving in M mode on the gearbox using some engine braking on a country drive. It didn't like it and the message said something along the lines of 'sub-optimal driving for efficiency'. It's a new-ish B3. I suspect is it something to do with charging / auxiliary power source and the 48V battery (and nothing to do with plugs). Other than that, I nearly always let it warm up for a couple of minutes first - starting it with the app.
Last edited by Deleted User 4868 on Fri Jan 05, 2024 9:02 pm, edited 1 time in total.
ChrisLF
Posts: 1566
Joined: Wed Apr 24, 2019 8:21 am
Location: Heart of England

Post by ChrisLF »

BuzBox wrote: Fri Jan 05, 2024 3:40 pm Can't rule out plugs - fuel-spark-bang. When an engine is juddering (miss-firing), the bang is missing. Suspect missing spark first, then fuel and so on - old school yes, but the fundamentals of the ICE have not changed in a 100+ years.
Yeah but I was referring to the fact that the dealer says it is a common problem with B3 and B4 engines and the fact that Volvo hadn't got a solution. Plugs can be defective but not that often and they should be a quick and easy diagnosis not 4 days! And if it's a common problem why no solution!

The basics haven't changed i.e. fuel and a spark but the rest of the engine has big time with all the tech required to squeeze the last iota out of every drop of fuel. It's not just fuel and spark anymore but all the complication including software.

Why have these engines started to have issues? Would have thought they were the tried and tested T4 etc. engines with the mild-hybrid added?

Whatever, there seems to be far too many problems arising with these cars now even allowing for the fact that forums highlight them. Bit worrying really.
2023 B4 Plus Dark FWD in Silver Dawn. Tinted Rear Windows. Spare Wheel & Tow Bar dealer fitted.

Gone - 2019 T4 R-Design FWD in Bursting Blue. Winter & Convenience Packs, Power Seat, Front Park Assist, Rear Camera, Spare Wheel & Tow Bar.
JFDIT
Posts: 1395
Joined: Tue Sep 28, 2021 5:21 pm

Post by JFDIT »

Issues raised here are probably not from a single cause.
XC40 MY24 B4 Ultimate Dark, Black Leather, Crystal White, 20" Rims
Lincolnshire England.
Volvobadger
Posts: 55
Joined: Mon Oct 24, 2022 10:57 pm

Post by Volvobadger »

Could it be something that's happening since the latest software update? Mine didn't do this until after v2.13.1 was installed in December. Coincidence?
ChrisLF
Posts: 1566
Joined: Wed Apr 24, 2019 8:21 am
Location: Heart of England

Post by ChrisLF »

JFDIT - Which is even more of a concern, as said far too complicated.

Do others get strange noises from the engine/transmission on occassion? Sometimes when almost coming to a halt and then pulling away again there is a metallic grating noise as it restarts and last night when moving the car after my wife came back it made metallic noises when I started it and still in Park as though something was activating. Not really bad but very noticeable. I've been driving cars for years, both manuals and autos which just drove as they should without these extraneous noises etc. It's just not the refined experience expected.

I haven't even done a thousand miles yet but these noises and the "whooping" are starting to get unacceptable. On the open road it's lovely and smooth and quiet but this other behaviour is spoiling things.
2023 B4 Plus Dark FWD in Silver Dawn. Tinted Rear Windows. Spare Wheel & Tow Bar dealer fitted.

Gone - 2019 T4 R-Design FWD in Bursting Blue. Winter & Convenience Packs, Power Seat, Front Park Assist, Rear Camera, Spare Wheel & Tow Bar.
Post Reply