Infotainment system failure

Faults and Technical chat for the Volvo XC40
johnd
Posts: 104
Joined: Sun Nov 25, 2018 9:58 am

Re: Infotainment system failure

Post by johnd » Sun Mar 10, 2019 6:37 pm

There's part of me that's starting to think this sort of issue is almost inevitable with modern computer-controlled systems. There's much to like about them and reliability is excellent, say 99.99%. But that's not 100.000% of course. I expect that I'll have to get used to the very occasional glitch, at least as long as eg it resets itself or at least after ignition off for a period.

I suspect the main problem is that system fault-logging hasn't properly caught up with the added complexity of modern car electronics. What's the betting that no error code has been logged or, even if it has, that it doesn't give much clue as to the underlying cause of the issue.

niteshade
Posts: 16
Joined: Sun Oct 07, 2018 7:04 pm
Location: Nicosia, Cyprus

Re: Infotainment system failure

Post by niteshade » Sun Mar 10, 2019 6:47 pm

johnd wrote:
Sun Mar 10, 2019 6:37 pm
There's part of me that's starting to think this sort of issue is almost inevitable with modern computer-controlled systems. There's much to like about them and reliability is excellent, say 99.99%. But that's not 100.000% of course. I expect that I'll have to get used to the very occasional glitch, at least as long as eg it resets itself or at least after ignition off for a period.

I suspect the main problem is that system fault-logging hasn't properly caught up with the added complexity of modern car electronics. What's the betting that no error code has been logged or, even if it has, that it doesn't give much clue as to the underlying cause of the issue.
True, I guess we have to get used to these random glitches.
However as long as the system reboots after a few minutes it's not too bad.. :roll:

Something similar happened a couple of months ago though it was restricted to the drivers display. The navigation map blacked out and the popup menu wouldn't appear. Again this resolved but not after a few minutes but the next time i restarted the car.

When i mentioned this incident to the garage during the first oil change service, they confirmed that it had been logged by the car.
D3 R-Design / Bursting Blue

Stevie01
Posts: 9
Joined: Tue Apr 16, 2019 1:48 pm
Location: Melbourne Australia

Re: Infotainment system failure

Post by Stevie01 » Fri Nov 29, 2019 12:31 pm

My centre screen went completely black tonight when I was on the navigation screen. The radio still worked as did the navigation in the instruments. Drove the car home (about 15 minutes) and it never came back to life. Annoying, and will be booking it in to get it looked after.
T5 AWD R Design Pro / Bursting Blue. 20" / Tech Pack / Lifestyle Pack and Harman Kardon

aj05
Posts: 75
Joined: Thu Jun 07, 2018 12:11 pm

Re: Infotainment system failure

Post by aj05 » Fri Nov 29, 2019 4:29 pm

Not had the screen black out when driving but occasionally the system is reluctant to boot up when first getting in. The loading message just sits there except for the navigation app which nearly always loads then after a minuet or so the system reboots and so far every time this has happened it loads correctly. I asked dealer to check this on 3mnth service but car not logged any errors. when this happens you can still start and drive the car with out any problems a friend of mine is a software engineer and thinks it just cant find a parameter it needs to boot in one of the loading apps and this stops the rest loading. Im not sure but it seems to happen if the car has not been used for a couple of days

reko
Posts: 1
Joined: Wed Jan 15, 2020 9:33 pm

Re: Infotainment system failure

Post by reko » Wed Jan 15, 2020 9:41 pm

This morning my infotainment system blacked out, while its not the first time - it happens so sporadically i thought nothing of it... However right after it came back to life (under 30 seconds), luckily while i was at a stop light the engine cut out - stalled. That had never happened before. :!: :?: I was at an incline so if i had taken my foot off the break it would have rolled (so i was in neutral). I started the car and was relieved that it restarted, the radio went on right away the infotainment a little slower. when the light changed i found myself in park bc the car somehow reset at some point when i restarted.

I called the dealership once i got into work and taking it in tomorrow morning to be checked out.

Michaelxc40
Posts: 138
Joined: Mon Mar 05, 2018 9:57 am
Location: Wakefield

Re: Infotainment system failure

Post by Michaelxc40 » Fri Jul 31, 2020 9:37 pm

Yesterday whilst driving on the motorway there was a high pitch electronic screeching sound came through the speakers, this was followed by the centre screen going blank then the main driver screen going blank. I left the motorway at the next junction, switched off the engine, re started all seemed ok, then about 10 mins later the same thing happened again. This time i got out, locked the car then re started. Luckily no issues today, will monitor and report if it happens again.
T5 First edition Crystal White

Post Reply