XC40 Hybrid Charge error

Faults and Technical chat for the Volvo XC40
Post Reply
Phila67
Posts: 3
Joined: Wed Jun 09, 2021 10:45 pm

XC40 Hybrid Charge error

Post by Phila67 » Wed Jun 09, 2021 11:05 pm

Hello
I have just taken delivery of a brand new XC40 R Design T4 Hybrid. I am having an issue with charging. Whether its through the 3 pin home charger or through a public charge station, I receive a Charge Error. The LED around the charge port remains red and the display says Charge error.

Has anyone had a similar experience? I have read the manual over and over and done everything exactly as described. Any help would be greatly appreciated.

As a side issue, the car makes strange intermitent noises for about 5 minutes after locking the vehicle. I look forward to any suggestions

Phila67

Felindre
Posts: 176
Joined: Wed Dec 23, 2020 2:19 pm
Location: South Wales, UK

Re: XC40 Hybrid Charge error

Post by Felindre » Wed Jun 09, 2021 11:23 pm

Phila67 wrote:
Wed Jun 09, 2021 11:05 pm
.

As a side issue, the car makes strange intermitent noises for about 5 minutes after locking the vehicle. I look forward to any suggestions

Phila67
Know nothing about the charge so can't help with that question,, however strange noises after locking vehicle, yes mine does that too. I've put it down to doing various bits of engine housekeeping.
B4 AWD Inscription , Fusion Red, Blond interior. Drivers Assist, Climate, Tinted rear windows and Towing pack.
Ordered 14 Dec 20, delivered 10 March 21

User avatar
m@rk
Posts: 122
Joined: Fri Dec 11, 2020 10:06 pm
Location: Lincolnshire, United Kingdom

Re: XC40 Hybrid Charge error

Post by m@rk » Thu Jun 10, 2021 8:59 am

The noises are normal for a modern car.
To rule out the charger/cable, hunt down your local Tesco with a free PodPoint charger and see if it works there.
XC40 T5 Recharge Inscription Pro - Denim & Blonde

Image

Phila67
Posts: 3
Joined: Wed Jun 09, 2021 10:45 pm

Re: XC40 Hybrid Charge error

Post by Phila67 » Thu Jun 10, 2021 11:59 am

Thanks guys
I have had to book it into a main dealer this morning. I tried using their charge point and same issue. I started to think it may be a fuse as there is a specific fuse for the charging unit, but alas that was OK. I wiil keep you posted on the outcome on Monday. I do question whether the dealership tested the vehicle before delivery as I am assuming it would have been present from day one.

User avatar
m@rk
Posts: 122
Joined: Fri Dec 11, 2020 10:06 pm
Location: Lincolnshire, United Kingdom

Re: XC40 Hybrid Charge error

Post by m@rk » Thu Jun 10, 2021 3:54 pm

Phila67 wrote:
Thu Jun 10, 2021 11:59 am
Thanks guys
I have had to book it into a main dealer this morning. I tried using their charge point and same issue. I started to think it may be a fuse as there is a specific fuse for the charging unit, but alas that was OK. I wiil keep you posted on the outcome on Monday. I do question whether the dealership tested the vehicle before delivery as I am assuming it would have been present from day one.
My car was delivered on the back of a truck but still came with 0% charge in it so I guess they don't charge them before delivery

Of course my whole order to delivery process was poor to the point I would never give said dealer any custom in the future (mines a company car so I don't get a say in where it comes from) so it having no charge and sod all fuel in it wasn't really a surprise
XC40 T5 Recharge Inscription Pro - Denim & Blonde

Image

Phila67
Posts: 3
Joined: Wed Jun 09, 2021 10:45 pm

Re: XC40 Hybrid Charge error

Post by Phila67 » Sun Jun 20, 2021 1:19 am

Quick update
The dealership spent a full day diagnosing the issue and in conjunction with Volvo Sweden have reached the conclusion that the entire charge unit is faulty. New one ordered from Sweden and due to be fitted next week

Post Reply